PSSM 1.0 FTF Avatar
  1. OMG Issue

PSSM_ — PSSM should align with fUML 1.4 and PSCS 1.2

  • Key: PSSM_-12
  • Status: closed  
  • Source: Model Driven Solutions ( Ed Seidewitz)
  • Summary:

    The fUML 1.4 and PSCS 1.2 specifications have now been completed. These updates make no functional changes to fUML or PSCS, but they migrate those standards to UML 2.5.1, which is consistent with PSSM. Therefore, PSSM should align with fUML 1.4 and PSCS 1.2, rather than fUML 1.3 and PSCS 1.1.

  • Reported: PSSM 1.0b1 — Fri, 26 Oct 2018 13:07 GMT
  • Disposition: Resolved — PSSM 1.0
  • Disposition Summary:

    Update specification for fUML 1.4 and PSCS 1.2

    Since fUML 1.4 and PSCS 1.2 are based on UML 2.5.1, it is no longer necessary for the PSSM specification to include fUML and PSCS syntax and semantics files based on UML 2.5.1. Instead, the PSSM syntax, semantics and test suite should just use UML 2.5.1, fUML 1.4 and PSCS 1.2.

    The normative references in the specification document need to be updated to fUML 1.4 and PSCS 1.2. In addition, since both the fUML and the PSCS specification documents are now re-organized to follow UML 2.5.1, any subclause references to the fUML and PSCS documents need to be updated.

  • Updated: Mon, 1 Apr 2019 18:19 GMT